Home » Beitrag veröffentlicht von webmaster

Archiv des Autors: webmaster

Windows Server aktivieren per PowerShell

In diesem kurzen Artikel beschreibe ich, wie man Windows Server 2019 per PowerShell aktivieren kann.

Ich hatte den Fall, das ich zwei virtuelle Maschinen auf einem Windes Server 2019 Hyper-V aufgesetzt habe. Beide konnten nicht über „Windows aktivieren“ aktiviert werden, der Versuch wurde mit einer Fehlermeldung quittiert.

Powershell mit Administratoren Rechten starten und den Befehl slmgr /upk eingeben und bestätigen. Nach kurzer Zeit sollte die folgende Meldung erscheinen.

Im nächsten Schritt den neuen Lizenzschlüssel installieren, Dazu den Befehl 

slmgr /ipk XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

Die XXXXX-XXXXX-XXXXX-XXXXX-XXXXX mit dem korrekten Lizenzkey ersetzen

Kurz darauf erscheint die folgende Meldung

Der Lizenzkey ist jetzt zwar hinterlegt, aber noch nicht aktiviert. Das erreicht man letztlich über den Befehl

slmgr /ato

Im Anschluss bekommt ihr eine Meldung die so aussehen sollte

Fehlermeldung „Ein für den Computer erforderlicher Medientreiber fehlt“ oder „Ein erforderlicher CD-/DVD-Laufwerkgerätetreiber fehlt“ beim Installieren von Windows

Bei der Installation von Windows 10 per USB Stick erhaltet ihr diese Fehlermeldung. 
Dieses Problem könnt ihr umgehen, wenn ihr den PC oder Laptop nicht von USB Stick installiert, sondern wenn möglich vom DVD Laufwerk. Es kann sich im Zweifelsfall auch um ein externes DVD Laufwerk handeln.

Scheinbar sind die Installationsdateien bei Stick und DVD doch unterschiedlich.

Buffalo Linkstation LS-QVL SMB 2 aktivieren

Da der Zugriff auf meine NAS nach dem Windows 10 Creators Update nicht mehr funktioniert hat, bin ich mal auf Ursachenforschung gegangen.

Das Problem war relativ schnell gefunden, mit dem Update hat Microsoft die Unterstützung für das SMB 1 Protokoll entfernt. Dies ist aus sicherheitstechnischer Sicht natürlich sehr sinnvoll, da das SMB 1 Protokoll doch diverser Sicherheitslücken aufweist. Unteranderem konnte der Wannacry Virus sich über diese Lücken ins System schleichen.

Was aber nichts an dem Umstand geändert hat, das ich keinen Zugriff auf meine NAS mehr hatte. Zunächst, um diesen Umstand temporär zu beheben, habe ich das SMB 1 Protokoll vorübergehend wieder aktiviert. Da gibt es letztlich zwei Wege das zu machen, der eine führt über den Weg Windows Features hinzufügen oder entfernen, der zweite geht recht schnell über die Powershell.

Wie man das SMB 1 Protokoll aktiviert findet ihr hier:

SMB 1 Protokoll über Systemsteuerung aktiven oder deaktivieren
oder Variante Nummer zwei hier:
SMB 1 Protokoll über Powershell aktiven oder deaktivieren

Zunächst sollte man die aktuelle Firmware für seine Buffalo Linkstation installieren. Das schaltet zwar das SMB 2 nicht automatisch frei, aber wohl erst mit der letzten verfügbaren Version ist es möglich, das SMB 2 zu aktivieren. Diese Version bringt Samba 3.6.3 mit, welcher SMBv2 ohne Probleme unterstützt, denn sonst würde die folgende Anleitung auch nicht funktionieren.

Die Firmware für die Linkstation LS-QVL findet ihr unter dem folgenden Link:

 

Für die anderen Buffalo Modelle findet ihr unter dem Menüpunkt Support die Möglichkeit für euer Modell die entsprechende Firmware zu suchen.

Um Zugriff auf die Buffalo NAS zu bekommen, brauchen wir Root Zugang auf dem System. Das erreichen wir mit dem ACP Commander

Download

Nachdem Download installieren, eventuell meldet sich das Programm mit dem Hinweis das Java erforderlich ist, das müsst ihr ggf. dann noch installieren.

Der eigentliche Ablauf mit dem ACP Commander ist schnell erledigt. Beim Start des ACP Commanders wir die NAS automatisch gefunden.

  1. Administrator Kennwort der NAS unter Admin Password eintragen
  2. Mit GO bestätigen
  3. Enable SSH klicken
  4. Set Root PW ausführen
  5. Es öffnet sich ein Dialogfenster, hier das gewünschte Kennwort für den Root eintragen und sich merken oder aufschreiben (unsicher, daher nicht die Ideallösung)
  6. Bestätigen mit OK

Fertig, damit ist das Root Passwort jetzt gesetzt. Für den Fall das es mit dem ACP Commander GUI nicht funktioniert, findet ihr hier noch eine Version die ohne Grafische Oberfläche funktionieren sollte.

Man kann jetzt den komplizierteren Weg über Putty wählen um dort dann per Kommandozeile die benötigten Änderungen in der NAS vorzunehmen.

Allerdings bin ich durch Zufall über eine ganz elegante Lösung gestolpert, die auch anwendbar ist, wenn man kein Unix Spezi ist.

Hier kommt das Programm WinSCP ins Spiel, WinSCP ist ein beliebter SFTP-Client und FTP-Client für Microsoft

Download WinSCP

Programm installieren und starten. Ihr könnt dann eine neue Sitzung aufbau, dazu tragt ihr in die Felder die erforderlichen Daten ein.

Nach der Anmeldung landet ihr im Root Verzeichnis, dort befindet sich eine smb.sh. 

Es gibt eine zweite smb.sh im Verzeichnis /etc/init.d/

Ich hatte zunächst nur die smb.sh im Verzeichnis /etc/init.de/ angepasst, so wie ich es bis dato in den anderen Anleitungen gelesen habe. Das hat aber das SMB 2 Protokoll in der NAS nicht aktiviert. Habe dann noch mal die smb.sh im Verzeichnis root ebenfalls angepasst, danach war alles wie gewollt.

Bevor ihr die Dateien aber bearbeitet macht euch Sicherheitskopie davon.

Wählt die runtergeladene Datei smb.sh aus und klickt mit der rechten Maustaste drauf.

Im folgenden Dialog wählt ihr einfach „bearbeiten“ und es öffnet sich der Editor.

Jetzt sucht ihr in der Datei den folgenden Abschnitt:

Kleiner Tipp vorweg, kopiert den ersten Satz vom Code, klickt auf auf das Fernglas im Menü des Editors , fügt den Satz in das Suchfenster ein und geht auf suchen, das geht definitiv schneller wie sich durch den Text zu scrollen und zu suchen.

/usr/local/sbin/nas_configgen -c samba
if [ $? -ne 0 ]; then
echo "$0 configure fail"
exit 1
fi

und ändert den wie folgt ab


/usr/local/sbin/nas_configgen -c samba
if [ $? -ne 0 ]; then
echo "$0 configure fail"
exit 1
fi
/bin/sed -i '3i\\
min protocol = SMB2\\
max protocol = SMB2\\
' /etc/samba/smb.conf

Im Anschluß die smb.sh wieder hochladen und die NAS neu starten. Solltet ihr auf eurem PC noch das SMB 1 Protokoll aktiviert haben, so ist jetzt ein günstiger Zeitpunkt, diese zu deaktiveren und den PC neu zu starten, während die NAS ebenfalls neu startet.
Wenn ihr alles richtig gemacht habt, dann habt ihr jetzt wieder uneingeschränkten Zugriff auf eure NAS ohne das SMB 1 Protokoll nutzen zu müssen.

SMB 1 über Powershell aktivieren

Ein schneller Weg das SMB 1 Protokoll zu aktivieren oder zu deaktivieren ist der Weg über Powershell. Ich kann mir nur die Befehle dafür nicht merken, darum schreibe ich das mal hier auf 🙂

Zunächst Powershell als Administrator starten, dazu in die Suchmaske Powershell eingeben und „Als Administrator ausführen“ wählen

 

Jetzt erscheint das Powershell Fenster 

Hier bietet sich jetzt die Möglichkeit, verschiedene Befehle einzugeben. Die hier aufgeführten Befehle gelten ab Windows 8.1 aufwärts.

 

Um zum Beispiel den aktuellen Status Des SMB 1 Protokolls zu prüfen:

Get-WindowsOptionalFeature –Online –FeatureName SMB1Protocol

Zum Aktivieren des SMB 1 wird der folgende Befehl benötigt

Enable-WindowsOptionalFeature -Online -FeatureName SMB1Protocol

Zum Deaktivieren des SMB 1 wird der folgende Befehl benötigt

Disable-WindowsOptionalFeature -Online -FeatureName SMB1Protocol

Nach Aktivieren oder Deaktivieren ist jeweils ein Neustart erforderlich um die Änderungen wirksam zu übernehmen.

SMB 1 Protokoll über Systemsteuerung aktiven oder deaktivieren

Es gibt Situationen, da ist es erforderlich, trotz massiver Sicherheitsbedenken das SMB 1 Protokoll unter Windows 10 zu aktivieren. Seitdem Windows Creatures Update von 2017 ist das SMB 1 Protokoll standmässig deaktiviert. Mit dem Deaktivieren war auch schlagartig mein Zugang zu meiner Buffalo Linkstation nicht mehr möglich. Um das temporär wieder zu ermöglichen, bis ich eine andere Lösung für das Problem gefunden habe, habe ich das SMB 1 Protokoll wieder aktiviert.

Der schnellste Weg zur Systemsteuerung ist über das Suchfenster, einfach Systemsteuerung eingeben und in der Auswahl ausführen

Im zweiten Schritt „Programme“ auswählen

Dann „Programme und Features“

Jetzt den Menüpunkt „Windows Features aktivieren oder deaktivieren“

In der darauffolgenden Liste sucht ihr dann den Eintrag „Unterstützung für die SMB 1.0/CIFS-Dateifreigabe“ und setzt den Haken.

Mit OK bestätigen, Vorgang abwarten und den Neustart bestätigen. Der Neustart ist erforderlich, weil das Protokoll sonst nicht aktiv wird.

Nach erfolgtem Neustart sollte der Zugriff auf die Linkstation wieder funktionieren. 

Das Aktivieren des SMB Protokolls kann aber auch bei Problemen mit älteren Multifunktionsgeräte helfen, die plötzlich nicht mehr in einen freigegebenen Ordner am PC scannen möchten.

Computerkram.net ist online

Was soll ich sagen, heute ist dann mal mein Blog online gegangen.

Zur Zeit ist er sicherlich noch recht leer, ich hoffe ich kann das mit der Zeit ändern. Betrachten wir den Tag heute aber mal als „Geburtstag“ des Blogs.

 

Neueste Kommentare